Учет готовой продукции, ее отгрузки и реализации

курсовая работа

2.5 Инструкция разработчика

Создание конфигурации.

Для начала создадим пустую конфигурацию и укажем основные настройки.

1. Создаем пустой каталог «учет продукции»;

2. Открываем 1С:Конфигуратор;

3. Появляется окошко «Запуск 1С:Предприяния»:

4. Кнопкой [Добавить] создадим новую информационную базу, в появившемся окошке "Регистрация информационной базы" введем название базы "учет продукции", в качестве каталога базы укажем «учет продукции»;

5. В списке информационных баз появится строка "учет продукции".

6. Нажмем [ОК]. После появления на экране заставки "1С:Конфигуратор", возникнет окно "Выбор формата хранения данных". Укажем формат DBF, кодовая страница - 1251 (как на рисунке). Нажимаем [ОК];

7. Конфигуратор загружен

Начало работы с метаданными.

Мы имеем теперь пустую конфигурацию, готовую к работе. Настроим некоторые основные опции.

1. Для начала откроем окно метаданных. В меню Конфигурация выберем команду "Открыть конфигурацию";

2. Появилось окно со структурой метаданных;

3. Установим курсор на разделе "Задача";

4. Либо через меню Действие команда "Свойства", либо щелкнув правой кнопкой мыши и выбрав команду "Свойства", откроем окно со свойствами;

5. Настроим свойства задачи:

На закладке "Общие"

a. Идентификатор - Учет 1.0;

b. Синоним - Учет продукции;

c. Комментарий - учебная конфигурация;

На закладке "Задача"

d. Основной язык - Русский;

e. Округление - 1.5 до 2

f. Разрешить непосредственное удаление объектов - Да;

6. Нажимаем [ОК];

7. Теперь надо сохранить конфигурацию. Через меню Файл команда "Сохранить". Соглашаемся со всем, что появляется.

8. После сообщения о том, что реорганизация информации закончена, подтверждаем это нажатием [ОК];

Создание пользователя.

Для работы с создаваемой конфигурацией, просмотра результатов нашей деятельности мы создадим пользователя.

1. В конфигураторе в окне метаданных переключим закладку (внизу) на "Интерфейсы";

2. Меню Действие команда "Новый интерфейс";

3. Появилось окошко со свойствами нового интерфейса. Укажем название - "Администратор", меню операции не будем отключать, по умолчанию использовать будем (все равно, это пока единственный интерфейс);

4. Нажимаем [ОК];

5. Сейчас у нас нет ни справочников, ни документов и поэтому настраивать пользовательский интерфейс нам пока нечем;

6. В конфигураторе в окне метаданных переключим закладку (внизу) на "Права";

7. Мы видим, что по умолчанию при создании новой конфигурации, автоматически создается набор прав "Администратор";

8. В конфигураторе в окне метаданных переключим закладку (внизу) на "Метаданные";

9. Сохраним набор метаданных;

10. У нас есть интерфейс и набор прав. Переходим к созданию пользователя;

11. В меню Администрирование выбираем команду "Пользователи";

12. Появилось окно со списком пользователей текущей конфигурации (пока оно пустое);

13. Через меню Действие командой "Новый" создаем нового пользователя;

14. Появилось окошко со свойствами пользователя. Дадим ему имя "Программист", полное имя - Ваше ФИО, каталог пользователя укажем каталог "учет продукциипрограммист", расположенный внутри каталога базы. Программа нас спросит "Построить путь к каталогу относительно каталога БД?", мы согласимся;

15. Перейдем на закладку "Роль" в окне свойств пользователя;

16. Выберем права - "Администратор", интерфейс - "Администратор" и отключим контроль прав, это чтобы права были самые полные;

17. В списке пользователей появился наш "Программист". Дадим этому пользователю секретный пароль.

a. Установим курсор на пользователя "Программист";

b. Через меню Действие команда "Изменить пароль";

c. Появилось окошко с полем ввода пароля. Введем "123" и нажмем [ОК];

d. Подтвердим свой пароль "123" и еще раз нажмем [ОК];

e. Рядом с рожицей пользователя появилось изображение замка - этот пользователь имеет пароль, соответственно нет замка - нет пароля;

18. Сохраним список пользователей;

19. Закроем список пользователей

Справочник товаров

Создадим для начала справочник товаров.

· Создаем перечисление с единицами измерения. Для этого в окне метаданных ставим курсор на раздел "Перечисления" и создаем новое перечисление;

· Идентификатор - ЕдИзм, Синоним - Единицы Измерения, Комментарий - Стандартные Единицы Измерения;

· Нажатием на [Новый] введем новое значение перечисления;

· Идентификатор - кг, Комментарий - килограмм, Представление - кг.;

· Нажмем [ОК];

· В списке значений перечисления добавилось наше значение - "кг";

· Аналогично введем еще значения - шт/штука/шт., ящ/ящик/ящ. руб/рубль/руб. лист/лист/л. мерт/метр/м.;

Закроем окно редактирования перечисления. В окне конфигурации появилось наше перечисление;

1. Создаем справочник товары. Для этого установив курсор на раздел "Справочники" в дереве метаданных и создадим новый справочник;

2. Появляется окно конструктора;

3. Идентификатор - товары, Комментарий - справочник товаров;

4. Субконто не создаем - тут нужна компонента Бухгалтерия;

5. Вставляем команду в пользовательское меню;

6. Вот появилось окно свойств справочника. Доопределим свойства. Количество уровней ставим - 3, длина кода - 8, длина наименования - 50, группы сверху - Да, автоматическая нумерация - не нужна, контроль уникальности - не нужен, серии кодов - все равно, тип кода - текстовый, основное представление - в виде, одна форма для элемента и группы - Нет, редактировать - в диалоге;

7. Добавим реквизиты;

8. ЕдИзм - основная единица измерения, тип - П.ЕдИзм (П - здесь Перечисление), для элемента;

9. ЦенаП - цена поступления, тип число 7.2, неотрицательное, периодический, для элемента, изменяется документом и вручную; ЦенаР - цена реализации, тип число 7.2, неотрицательное, периодический, для элемента, изменяется документом и вручную;

10. Теперь создаем форму элемента справочника;

11. При нажатии на [Форма элемента] появилось окно редактирования формы элемента и диалог с перечнем реквизитов элемента справочника. Пометим все и нажмем [Вставить]. Форма заполнится элементами диалога и записями к ним.

12. Далее создаем константу "ЕдИзмПоУмолчанию". Для этого переключимся в окно с деревом метаданных, и в раздел "Константы" введем новую константу. Наименование - "ЕдИзмПоУмолчанию", Комментарий - "единица измерения по умолчанию", Тип - П.ЕдИзм;

13. Возвращаемся в форму элемента справочника;

14. Переключаемся на закладку "Модуль". Сюда мы напишем код:

15. Процедура ВводНового()

16. // предопределенная процедура

17. // при вводе нового элемента справочника

18. ЕдИзм=Константа.ЕдИзмПоУмолчанию;

19. // в поле ЕдИзм заносим значение из константы

20. КонецПроцедуры

21. Затем вводим константу "ПроцентНаценки", Комментарий - "процент наценки на приходную цену", тип - число 5.2;

22. Переключаемся на закладку "Модуль". В свойствах поля ЦенаП на закладке "Дополнительно" напишем формулу ЦенаП();

23. В модуле формы элемента напишем следующую процедуру:

24. Процедура ЦенаП()

25. ЦенаР=ЦенаП*(1+(Константа.ПроцентНаценки/100));

26. //Константа.ПроцентНаценки у нас в %

27. КонецПроцедуры

28. Работа с элементом справочника закончена. Можем закрыть его;

29. Возвращаемся в окно со свойствами справочника;

30. Начинаем редактировать форму группы. Она будет иметь самый примитивный вид;

31. Закрываем окно редактирования формы группы справочника;

32. Возвращаемся в окно со свойствами справочника;

33. Будем редактировать форму списка справочника;

34. В окне свойств справочника выберем по кнопке [Формы списка] из выпавшего меню пункт "Форма списка";

35. Появится диалог с перечнем реквизитов похожий на предыдущие, отметим, что нам еще нужно дерево групп и нажмем [Вставить];

36. Отредактируем размеры формы и элементов диалога и добавим две кнопки;

a. Первая кнопка Заголовок - Закрыть, Формула - #Закрыть. Эта кнопка будет закрывать форму списка

b. Вторая кнопка Заголовок - Печать, Формула - Печать().

37. Переключимся на закладку "Модуль" окна редактирования формы списка справочника. Впишем код:

38. Процедура Печать()

39. СпрТов=СоздатьОбъект("Справочник.Номенклатура");

40. // это мы создали в памяти копию справочника

41. СпрТов.ПорядокКодов();

42. // справочник мы желаем сортировать по кодам

43. СпрТов.ВыбратьЭлементы();

44. // открываем выбор элементов

45. Таб=СоздатьОбъект("Таблица");

46. // создаем объект для печатной формы

47. Таб.ИсходнаяТаблица("Таблица");

48. // указываем какую таблицу брать за основу

49. Таб.ВывестиСекцию("Шапка");

50. // формируем шапку печатной формы

51. Пока СпрТов.ПолучитьЭлемент()=1 Цикл

52. // пока есть очередной получаемый элемент

53. ТЭ=СпрТов.ТекущийЭлемент();

54. // временная переменная для краткости

55. Если ТЭ.ЭтоГруппа()=1 Тогда

56. // если текущий элемент справочника группа

57. Код=ТЭ.Код;

58. Наз=ТЭ.Наименование;

59. Таб.ВывестиСекцию("Группа");

60. // выводим строку для группы

61. Иначе

62. // просто элемент

63. Код=ТЭ.Код;

64. Наз=ТЭ.Наименование;

65. ЕдИ=Строка(ТЭ.ЕдИзм);

66. ЦенаП=ТЭ.ЦенаП.Получить(ТекущаяДата());

67. // а это как получить значение периодического реквизита!!!

68. // ТекущаяДата() - функция возвращающая текущее число

69. ЦенаР=ТЭ.ЦенаР.Получить(ТекущаяДата());

70. Таб.ВывестиСекцию("Элемент");

71. КонецЕсли;

72. КонецЦикла;

73. Таб.ТолькоПросмотр(1);

74. // а нечего редактировать!

75. Таб.ПараметрыСтраницы(1,100,1);

76. Таб.Показать("");

77. // делаем печатную форму видимой. Можно посылать на принтер

78. КонецПроцедуры

79. Теперь переключаемся в закладку "Таблица";

80. Рисуем шаблон нашей печатной формы. В секции "Шапка" все поля текстовые, в секциях "Группа" и "Элемент" - выражения.

81. Закрываем форму списка;

82. Закрываем окно свойств справочника;

83. Сохраняем конфигурацию;

Справочник контрагентов

Контрагенты это те фирмы, с которыми мы будем вести торговые операции. Займемся конструированием этого справочника.

1. Идентификатор: Контрагенты, Подчинен: нет, Количество уровней: 2, Код: 4, Тип кода: число, Серии кодов: подчинение, Наименование: 50, Основное представление: наименование, Группы сверху: да, Автонумерация: да, Уникальность: да, Одна форма для элемента и группы?: нет, Редактировать: в диалоге.

2. Добавляем реквизит "Адрес", тип - строка неограниченной длинны, используется для элемента;

3. Добавляем еще один реквизит "ДатаРаботы", тип - Дата, Сортировка - да, для элемента;

4. Создадим форму группы. Код создается автоматически, поэтому сделаем поле ввода кода в форме группы недоступным. В свойствах поля ввода укажем "Сделать недоступным" - да;

5. Форма группы готова. Закрываем ее;

6. Создаем форму элемента;

7. Код мы изменять не будем, поэтому поле ввода кода вообще удалим. Но мы хотим видеть этот код;

8. Для этого вставим элемент диалога - Текст. В свойствах текста очистим поле "Заголовок", а в поле "Формула" на закладке "Дополнительно" напишем Код. Шрифт сделаем покрупнее и пожирнее, и еще цвет выберем поярче - для красоты;

9. Войдем в свойства поля ввода "Адрес";

10. На закладке "Тип" укажем, что это поле у нас будет многострочным. После этого увеличим высоту поля так, чтобы в него могло поместиться несколько строк текста;

11. В модуле ничего писать не будем;

12. Закроем форму элемента;

13. Создадим форму списка;

14. Пусть в форме списка будут все поля нашего справочника, дерево групп - по желанию;

15. Ничего менять не будем и закроем форму списка;

16. Закроем справочник "Контрагенты";

17. Сохраним конфигурацию;

Справочник договоров с контрагентами

Идентификатор: Договора, Подчинен: С.Контрагенты, Количество уровней: 1 Код: 3, Тип кода: текст, Серии кодов: подчинение, Наименование: 35, Основное представление: наименование, Группы сверху: да, Автонумерация: нет, Уникальность: нет, Одна форма для элемента и группы?: нет, Редактировать: в списке.

1. Создаем новый справочник "Договора";

2. Комментарий - "договора с контрагентами", в меню включим;

3. Установим свойства справочника и введем дополнительный реквизит ДатаДоговора (тип - Дата, Сортировка - да, для элемента);

4. Создадим форму списка;

5. В свойствах колонки "Наименование" укажем, что она недоступна;

6. В свойствах колонки "Код" изменим Заголовок на "№ дог.";

7. В свойствах колонки "ДатаДоговора" изменим Заголовок на "от";

8. Передвинем эту колонку между колонкой "№ дог." и колонкой "Наименование";

9. В свойствах колонки "№ дог." на закладке "Дополнительно" введем формулу Дог();

10. В свойствах колонки "от" на закладке "Дополнительно" введем формулу Дог();

11. Теперь напишем в модуле процедуру:

12. Процедура Дог()

13. Дат = Формат(ДатаДоговора,"ДДДММММГГГГ");

14. // Дат - временная переменная, в нее мы при помощи функции Формат(,)

15. // заносим строковое представление даты из реквизита справочника

16. // ДатаДоговора в формате ДДММММГГГГ.

17. // Т. е. дата типа 04.09.00 будет представлена в виде

18. // "4 сентября 2000г."

19. Наименование = "№ "+СокрЛП(Код)+" от "+СокрЛП(Дат);

20. // А здесь из кода и временной переменной мы собираем текстовое

21. // представление договора

22. КонецПроцедуры

23. Закроем форму списка и справочник и сохраним конфигурацию.

Делись добром ;)